记载一次局域网突发网络环路处理进程——满是血泪51CTO博客 - 娱乐之横扫全球

记载一次局域网突发网络环路处理进程——满是血泪51CTO博客

2019年03月04日08时01分08秒 | 作者: 震轩 | 标签: 网络,环路,问题 | 浏览: 2496

这是自己做网络应急的一次进程描绘:

问题症状:

1、网络内俄然呈现断断续续,丢包比较严峻,无法操作事务

2、PING 网段虚地址比方62及两个实践地址60、61,断断续续

3、中心交流机S1上到其他网络影响不大,问题首要会集在区XX局及经营大厅。

4、夜间依然有丢包问题呈现

5、H3C 7503 CPU过高

Slot 1CPU usage:

98% in last 5 seconds

55% in last 1 minute

56% in last 5 minutes

6、R1联通线路不通(排查进程中发现)


原网络拓扑图:

网络结构相对简略,工作网内首要有vlan 3 vlan4vlan5 vlan6,经营厅首要vlan 3,曩昔整改XX单位的工作内网悉数经过H3C 7503衔接,中心S1和75之间经过trunk口进行互联装备;在中心交流机设置了vlan地址,考虑网络高可用性,使用了virtual-ip,S1的vlan3地址为60,s2的vlan3地址为61,他们的虚拟地址为62,因而vlan3下面的机器的网关都设置为62,其他的vlan也是相同;

interface Vlan-interface3

ip address x.x.x.60 255.255.255.192

vrrp vrid 3 virtual-ip x.x.x.62

vrrp vrid 3 priority 120

vrrp vrid 3 track 1 reduced 30


S1 trunk接口装备如下:

interface GigabitEthernet1/0/48

port link-mode bridge

port link-type trunk

undo port trunk permit vlan 1

port trunk permit vlan 2 to 4094

其他接入交流机都是经过75上的access方法进行衔接,装备如下:

interface GigabitEthernet2/0/41

port access vlan 4

interface GigabitEthernet2/0/43

port access vlan 5

interface GigabitEthernet2/0/46

port access vlan 6


开端置疑或许的原因:

1、网络环路?

2、病毒***?

3、装备问题?

4、设备问题?

5、网线问题?

6、其他?


为处理问题调整下网络并参加主动要挟设备测验:


为了扫除毛病,首要做了剖析,判别网络环路和病毒ARP或许性较高,在中心交流机上布置了主动要挟发现设备,并将做了端口镜像,还得自己做呀,就是将75和接入交流机的数据仿制一份到S1的g1/0/30,g1/0/30接主动要挟发现设备数据口。

Mirroring-group 1 local(设置镜像组)

Mirroring-group 1 monitor-port Gigabitethernet 1/0/30(设置镜像的意图端口)

Mirroring-group 1 mirroring-port Gigabitethernet 1/0/48 both (设置镜像的源端口 both为双向)

抓包进行主动要挟剖析,发现要挟比较少截止晚上就几条病毒***,还有部分ARP风暴,可是量不大。


排错进程意外发现:

刚开端我以为有时候ping 60通61不通,60不通,61通….是装备有问题,不断呈现vrrp切换,我决议将中心交流S1和中心交流机S2之间的线路断掉,只保存一条主线路;可是断掉之后发现,到网关通,可是到上联上级单位不通,置疑R1联通线路有问题,一看公然R1联通线路断掉了,这个发现是意外,后来联通公司洽谈上级单位处理处理问题,问题原因是端口洽谈。


因而置疑为网络环路或许设备有问题可行性大,因为中心交流机S1上其他vlan接的电脑没有问题(除75上接的之外维护电脑A),所以开端置疑问题会集在75上。为了便于排错咱们将网络进行了改造,将其他vlan接入交流机别离接到中心交流S1上,不在衔接75,而和75并行。

做如下试验1:

1、将一切接入交流机和75悉数在中心交流机s1上拔掉网线

2、顺次接入,并将测验电脑B接在测验的交流机下面

3、开端ping vlan 3网关

4、Vlan 4 5 6接入交流机问题很小,电脑B丢包不严峻(有丢包是因为该笔记本没有装准入模块,导致准入设备会发ARP诈骗包,这是后期发现这个问题的管理员同志没有告诉我)

5、接入75交流机,然后将电脑B接入75上,发现症状比较严峻,开端判别或许是75上的问题


替换设备试验2如下

为了扫除是设备毛病,拿一个24口交流机进行测验,将线悉数网线接上,有问题,特别是接大厅的线路时,十分显着,判别问题会集在环路或许线路。


处理环路试验3如下

首要在75上启用STP

1、Stp enable

2、dis stpbrief  检查生成树

3、发现会有一些改变,可是不显着,有个接口down可是,问题还在,或许环路不知一处。

%Feb 2117:01:10:856 2014 xx-S1 MSTP/6/MSTP_NOTIFIED_TC: Instance 0s GigabitEthernet x/x/x was notified a topology change.


4、将75上线路悉数拔掉,只留下电脑B,发现ping正常。

5、断定问题在大厅机器有环路,决议去找环,发现大厅网线紊乱,有分线的,乱接的,欠好排查。

6、封闭大厅的小交流机及HUB

7、抛弃找环,决议先应急从头布线,经过巡线仪找到一条到大厅的线路,接在方才拿的24口交流机上,然后从24口交流机顺次在接到大厅机器电脑上,发现ping都是正常的。

8、将大厅40多台机器悉数整理结束,保证没有环路,线路正常。

9、整理机房线路,将75上不必线路悉数整理。

10、测验,一切正常。



虽然是次不太杂乱的排查进程,也没有找到详细的环路方位,也没有杂乱的装备和惊心的局面,可是往往是些简略的问题,给网络带来丧命的风险。期望这个进程给我们有协助!





版权声明
本文来源于网络,版权归原作者所有,其内容与观点不代表娱乐之横扫全球立场。转载文章仅为传播更有价值的信息,如采编人员采编有误或者版权原因,请与我们联系,我们核实后立即修改或删除。

猜您喜欢的文章