思科和华为交换机常用命令之比照学习51CTO博客 - 娱乐之横扫全球

思科和华为交换机常用命令之比照学习51CTO博客

2019年02月28日12时47分36秒 | 作者: 昂然 | 标签: 交换机,思科,华为 | 浏览: 1436

    思科和华为交换机应该是网络项目中咱们触摸比较多的了,这两种交换机的常用指令各有不同,本文结合网络项目中两种交换机的常用指令从比照的视点协助咱们来学习。

一、调试指令

思科:

Switch#show  run   显现一切装备指令
Switch#show   ip   inter   brief   显现一切接口状况
Switch#show vlan  brief   显现一切VLAN的信息
Switch#show   version   显现版别信息

华为:

[Quidway]dis cur  显现一切装备指令 [Quidway]display interfaces   显现一切接口状况 [Quidway]display vlan all     显现一切VLAN的信息 [Quidway]display version    显现版别信息                 

二、接口装备指令

思科:
Switch(config)#interface f0/8  进入接口视图
Switch(config-if)#no shut  此指令敞开接口
Switch(config-if)#description to server01 端口描绘
Switch(config-if)#ip add 192.168.1.100 255.255.255.0 设置接口IP    

华为:
[Quidway]interface e0/1  进入接口视图
[Quidway]undo  shutdown  此指令敞开接口
[Quidway]description  to server02   端口描绘
[Quidway]ip add 192.168.1.102 255.255.255.0   设置接口IP

三、VLAN装备指令:

思科:
树立和删去VLAN
Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# no vlan 20
Switch(vlan)# exit
将端口分配给一个VLAN
Switch(config)# interface f0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 20
设置VLAN TRUNK
Switch(config)# interface f0/24
Switch(config-if)# switchport mode trunk
Switch(config-if)#switchport trunk allow vlan {ID|All} 
Switch(config-if)# switchport trunk encapsulation dot1q

华为:
树立和删去VLAN
[Quidway]vlan 30
[Quidway]undo  vlan 30 
将端口分配给一个VLAN
[Quidway]int ethernet0/1
[Quidway-Ethernet0/1]port access vlan 30( port default vlan 30)
或[Quidway]vlan 30             
[Quidway-vlan3]port ethernet 0/1  在VLAN中添加端口
[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4   在VLAN中添加多个接连端口
设置VLAN TRUNK
[Quidway]int e0/24 
[Quidway-Ethernet0/24] port link-type trunk
[Quidway-Ethernet0/24]port trunk permit vlan {ID|All} 

四、端口镜像装备
思科:
装备镜像源端口
Switch(config)#monitor session 1 source interface gigabitEthernet 0/2 - 5 rx
上面指令最终一个参数:
both  监听双向数据,默以为both
rx    接纳
tx    发送
 
装备镜像意图端口
Switch(config)#monitor session 1 destination interface gigabitEthernet 0/6

删去镜像端口
Switch(config)#no monitor session 1

华为:
将端口E0/2装备为监控端口

[Quidway]monitor-port Ethernet 0/2

端口E0/1装备为镜像端口

[Quidway]port mirror Ethernet 0/1

或许直接装备监控端口和镜像端口

[Quidway]port mirror Ethernet 0/1 observing-port Ethernet 0/2

删去镜像[Quidway]undo    monitor-port

五、冗余装备
思科HSRP:
Switch# interface Vlan20
  ip address 172.29.197.33  255.255.255.248
 standby 20 ip 172.29.197.53
 standby 20 priority 105   优先级
 standby 20 preempt        抢占
 standby 20 track GigabitEthernet0/25  decrement 10   盯梢端口假如DOWN了优先级减10

华为VRRP:
[Quidway]interface Vlanif30
 ip address 172.29.197.9   255.255.255.248
 vrrp vrid 30 virtual-ip 172.29.141.11
 vrrp vrid 30 priority 150  优先级
 vrrp vrid 30 preempt-mode   抢占
 vrrp vrid 30 track interface GigabitEthernet0/0/18 reduced 60  盯梢端口假如DOWN了优先级减60

六、设置安全长途拜访
思科设置vty安全拜访: 
R1(config)# access-list 1 permit 192.168.2.5 
R1(config)# line vty 0 4 
R1(config)# access-class 1 in 

华为设置vty安全拜访:
[Quidway]acl number 2000
        rule 1 permit source 172.29.181.150  0
        rule 2 deny 
[Quidway]user-interface vty 0 4
         acl 2000 inbound

七、NTP装备
思科:
Cisco6509#show clock    显现时刻
Cisco6509#clock set 14:00:00 30 Sep 2011 设置时刻
Cisco6509(config)#ntp server 202.198.0.102 设置与其他时刻服务器同步
Cisco6509(config)#clock timezone beijing +8  设置时区

华为:
[Quidway]dis clock  显现时刻
[Quidway]clock datetime 23:30:00 2011/11/16  设置时刻
[Quidway]ntp-service unicast-server 202.198.0.102  设置与其他时刻服务器同步
[Quidway]clock timezone  E8  add  08:00:00  设置时区

八、静态路由装备
思科:
ip route <意图网段> <意图网段掩码><下一跳>
Cisco6509# ip   route       0.0.0.0  0.0.0.0   10.65.1.2      静态路由
Cisco6509#ip route  0.0.0.0  0.0.0.0  192.168.3.1 150  起浮静态路由办理间隔为150

华为:
[Quidway] ip  route-static   0.0.0.0  0.0.0.0   10.65.1.2

[Quidway]ip route-static 0.0.0.0  0.0.0.0 192.168.3.1   preference  150


九、可网管装备
思科:
Switch(config)#snmp-server community sunion ro 装备本交换机的只读字串为sunion
Switch(config)#snmp-server community sunion rw 装备本交换机的读写字串为sunion
Switch(config)#snmp-server enable traps 答应交换机将一切类型SNMP Trap发送出去
Switch(config)#snmp-server host 192.168.190.1  traps sunion 指定交换机SNMP Trap的接纳者为192.168.190.1,发送Trap时选用sunion作为字串

华为:
[Quidway]snmp-agent community read  datanms 装备本交换机的只读字串为datanms
[Quidway]snmp-agent community write  datanms 装备本交换机的读写字串为datanms
[Quidway]snmp-agent sys-info location BeiJing China 设置交换机的方位信息
[Quidway]snmp-agent sys-info version all  设置交换机支撑一切的SNMP协议版别
[Quidway]snmp-agent target-host trap  address udp-domain 192.168.190.121 params securityname datanms  指定交换机SNMP Trap的接纳者为192.168.190.121 ,发送Trap时选用datanms作为字串

   好了,经过以上九点的举例,信任咱们对项目中两种交换机的常用指令应该比较明晰了,当然更多的指令运用和技巧需求咱们不断的堆集。

本文的授权下载:http://down.51cto.com/data/290806

版权声明
本文来源于网络,版权归原作者所有,其内容与观点不代表娱乐之横扫全球立场。转载文章仅为传播更有价值的信息,如采编人员采编有误或者版权原因,请与我们联系,我们核实后立即修改或删除。

猜您喜欢的文章